
QGIS Level 2 – Stuart Ladd

Introduction
This guide will take you through some more advanced, field work-related tasks that can be done
with QGIS. It assumes you have successfully been through the Level 1 exercises.

• This guide is aimed at QGIS v2.6 which has some performance improvements although a
number  of  things  may  have  changed  in  the  interface  –  development  is  fairly  rapid!  
N.B. At the time of finalising this guide, QGIS was at v2.12. The interface has changed but
most  of  the  principles  are  the  same.  Outdated  versions  can  be  downloaded  here:
http://qgis.org/downloads/

• It's still a good idea to save the project file regularly!

• A mouse will be useful if using a laptop. 

• Ensure you have set up your installation to default to EPSG 27700 OSGB 1936 / National
Grid as we are working within the UK using the Ordnance Survey National Grid (see Level
1 guide for  instructions  on doing this  for  both new projects  and newly added layers).
Failure to do this will cause problems later.

This guide will go through the following tasks:

• Exercise  1:  Digitising  site  plans.  Converting  a hand drawn site  plan to a digitised GIS
project with data attached.

• Demonstration:  Digitising aerial  photos.  Tracing features from aerial  photographs into a
project.

• Exercise 2: Field walking. Setting up a field walking grid and logging finds data.
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Exercise 1 – Digitising Plans

1 Introduction
This guide will take you through the process of taking a 'flat' pencil-drawn site plan (map) that has 
already been scanned in and turning it into a useful, multi-layered GIS project. Some knowledge of 
the site hand-drawing conventions would be useful, but not essential.

Digitising is a process is akin to data-entry but we are entering spatial information in to a GIS 
instead of numbers in to spreadsheet. With an accurate GPS or photogrammetry, this process may
become redundant in the near future! However, it is tried, tested and reliable.

1. Open the prepared project in Exercises/Exercise 1 – Digitising/Ex 1 – Digitising.qgs

Four layers should appear in the Layers Panel. If you don't have a layers panel, got to View > 
Panels > Layers Panel

2 Georeferencing
The first step is to get scans of our site plans into QGIS as raster images. There are two scanned 
plans in Exercises/Exercise 1 – Digitising/Scans. 

1. Georeference the site plans (Raster >
Georeferencer > Georeferencer… and
within the Georeferencer window, File >
Open Raster) using some of the
coordinates written on the plan. This is
something we did on the Level 1 course
for National Grid co-ordinates of X and Y.
Here we are using our arbitrary local grid
starting at x=100, y=100. Remember to
use two point, then press 'play'.

2. Under the Transformation settings
window (which appears when you press
the 'play button'), make sure 
Transformation Type is Helmert. Also,
ensure the target resolution is 
Horizontal: 0.005 / Vertical: -0.005 (this
keeps the file size smaller i.e. output files
have 1 pixel for every 5mm on the map).
Also, untick 'Use 0 for transparency'.

3. Repeat for the second scan (there
should be two scan files).

4. Close the georeferencer when both plans are displayed overlapping in the right place in the
main window. You will want to slide the plan layers down the list so that they are displayed 
below the digitising layers. If anything looks wrong, remove the scan layer from the layers 
panel (Right click > Remove), go back to the georeferencer and check your coordinates and
Transformation settings.

In practice you would use a GPS or theodolite in order to accurately locate your site's drawing grid 
points. Here we are using an arbitrary grid, but it is in metres so all digitised features will be to 
scale.
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There are two plans for this site. We can digitise both at the same time as they overlap. In practice 
you might digitise one at a time.
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3 Layers
Each part of the site plan will be digitised to a different layer. A layer scheme has already been set
up for you.  This is designed to correspond to the conventions on the scanned drawing, but in
practice this is open to modification according to project requirements.

In the QGIS project,  the layers have already been styled to make them easier  to understand
(although they are currently empty of shapes!). Some layers have attribute data attached to them.

The table below summarises each layer,

Layer name Description Type 
(point/line/polyg
on)

Attribute data Hand drawing 
convention

Limit of 
excavation

Defines the area that 
was open for 
excavation

Line id, unused (but 
you could add 
an attribute for 
trench or test pit 
number)

Dot-dashed line

Archaeological 
feature

The full area of an 
archaeological 
feature: ditches, post 
holes, pits

Polygon Context_ID (the 
number 
assigned to the 
feature)

Solid lines

Excavated slot The sub-set area of a 
feature excavated by 
hand

Polygon Context_ID (the 
number 
assigned to the 
feature at this 
slot)

Dot dashed line 
again! (But 
within a feature)

Section Line The line on the plan 
indicating where a 
vertical section was 
drawn

Line Section_ID (the 
number 
assigned to the 
section drawing)

Usually arrows 
and number s.# 
next to the edge 
of an excavated 
slot

Note:  We won't  be  digitising  the 'break of  slope'  or  hachures  approximating the profile  within
excavated slots in this guide, but normally we would use an additional line layer and trace into that.

4 Limit of Excavation
In QGIS you can only edit layers if they are unlocked ('toggled') for editing.

We will begin by digitising our limit of excavation (the edge of the excavation area on the plan).

1. Select the Limit of Excavation layer.

2. Enable editing for the layer (right click on Limit of Excavation, then click Toggle editing). A 
pencil-like symbol will appear next to the layer name when it is unlocked.

3. Select the Add Feature tool  (or click Edit>Add feature). 
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4. Using the left mouse button only,
trace around the limit of excavation line
on the plan. You can use the middle
mouse button to drag the map around
and scroll in/out while you do this. A red
line will show how far you have got. If
you make a mistake, press the 
Del/Delete key on your keyboard to
step back.

5. Remember you can move around the
map while doing other tasks but using
the middle mouse button to drag the
map around or to scroll up and down to
zoom in and out.

6. When you have traced the whole line
back to the start, press the right mouse
button. This tells QGIS that the shape
is complete. A window will pop up
prompting for 'id'. Leave it blank and press OK.

7. It is a good idea to save the changes for this layer now. Right click on the layer and click 
Save Layer Edits.

If you can not see your changes, make sure the Limit of Excavation layer is at the top of your 
layers panel (you can drag layers up and down within the panel) and that the scans are at the 
bottom.

5 Snapping
When we digitise the rest of the layers, we will probably want shapes to line up precisely with the
Limit of Excavation and each other. So the corner points at the ends of the ditches, say, line up
exactly on the lines of the Limit of Excavation.

To do this we have to tell QGIS which layers to snap to – i.e. when we trace around shapes, the
pointer will automatically click into place along existing lines.

1. Click Settings>Snapping Options.

2. Tick Limit of Excavation, Archaeological Feature and Excavated Slot and set each “Mode” 
to 'Vertex and Segment', Tolerance to '10' and units to 'pixels' as below.

3. Press OK.

We are now ready to digitise the rest of the drawing.
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Node editing – For reference
The small red crosses indicate nodes (corners) along your lines. These remain visible while a layer
is editable. There is a tool to manipulate these if you make a mistake in the initial digitising.

1. Pick the node tool 

2. Select the layer you want to correct

3. Click on the edge of a shape to select it for editing – the crosses will now have red boxes 

around them 

4. Click and drag boxes to the right place.

5. If you need more points on a line, double click on the line where you want them and they 
will be added.

6. Save changes to the layer!

7. Remember to switch back to the Add Feature tool if you want to trace a new shape.

Deleting shapes – For reference
Should you make a mistake and close a shape before finishing it, you can either add nodes as 
above or delete the shape entirely and start again

1. Select: 

2. Click and drag a rectangle around shapes you do not want

3. Click Delete feature:   

4. If you accidentally select the wrong shape, use the Deselect all button: 

7 Archaeological feature
It is usually best to proceed in this order: Archaeological Features fit to the Limit of Excavation;
Excavated Slots snap to features; and Section Lines usually snap to Excavated slots. We will trace
one each of these, then you may proceed to repeat for the rest of the drawing.

1. Select the Archaeological Features layer and turn editing on
(Right click on layer > Toggle Editing).

2. Select the Add Feature tool. 

3. Trace  around  the  ditch  numbered  101.  This  time,  a  red
polygon will  show the area digitised so far.  If  you make a
mistake, press the Del/Delete key on your keyboard to step
back.  The  pointer  will  snap  onto  the  line  of  the  Limit  of
Excavation at either end of the ditch. The number of points
you use is a matter  of  preference,  just  try to capture any
changes in direction along the lines of the feature.

4. When finished, press the right mouse button. You will now
be prompted to enter the Context_ID for this shape, type in
101 and press enter.
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5. Save changes to the layer (right click, Save Layer Edits).

6. Continue with other features. For earlier features cut by others, follow the cut lines of the
overlying features (not where you think the feature would have been).

You can repeat this for some of the other features now, or carry on to the next layer for this feature.
SAVE  LAYERS  OFTEN! Remember  there  is  a  difference  between  saving  a  project  (which
manages the list of layers, their order and their styles) and saving layers (which contain the spatial
data) – the latter tends to be more crucial as you digitise more features.

8 Excavated Slot
Look at the area indicated by  101. This represents the portion excavated by hand. We want to
digitise this into our Excavated Slot layer. The process is the same as above

1. Click on the Excavated Slot layer in the Layers
panel

2. Toggle editing for the layer

3. Choose the 'Add Feature' tool

4. Trace the shape around that slot

5. Right click to close the shape. You will be asked
for Context_ID, enter 101. Note that the shape is
displayed with a label '101', this is because the style (already set up) for this layer is set to 
use Context_ID for labels.

6. Repeat this for the Excavated Slot marked 103.

Note: Although we numbered the ditch 101 for the whole feature, it has two numbers where 
excavated. This is to distinguish the finds from the two slots but the Archaeological Feature layer 
can only store one of these numbers – a potential weakness in this data scheme!

9 Section Line
Now digitise the two section lines marked s1 and s2 on the plan. 

1. Toggle editing for the Section Line layer.

2. Add Feature tool 

3. Trace the line for Section 1 (s1), right click to finish and enter '1' for Section_ID when 
prompted.

4. The section numbers will be displayed automatically (because of the layer's style).
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10 Repeat!
You will have to repeat the process for the whole drawing eventually! Spot the deliberate mistake – 
ditch 105 does not line up across the two plans. Someone has made a mistake in drawing on site. 
At this point, reference to photos or a best guess may be required! You may need to edit individual 
nodes.

1. To hide the editing nodes (crosses), disable editing for each layer (right click on layer, then 
click Toggle Editing).

2. Finally, hide the original plans by un-checking the box next to those layers

Your map should now look something like this:

11 Post-excavation use
Some of the benefits of digitising all this data in QGIS come from the analysis you can perform 
without leafing through all the hand plans. (In this case there were only two, but there may be 
hundreds!)

Obviously you could now add in background mapping if wanted (if our grid points were on the OS 
grid – in this example they are not).

A brief example: we might want to measure the diameter of a pit.

1. Choose the ruler tool 

2. Left click to start measuring, right click to select the final point. Use this to measure the 
diameter of pit 107.

3. Do the same for the length of ditch 101.

4. What about the length of the 6-post structure (from posthole 111 to 115)?

Try using the identify tool  (covered briefly in Level 1) by clicking on an excavated slot. This will 
display attribute data for all where clicked. It also gives additional data such as polygon area or line
length.
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Further on during the post excavation process, additional data such as phase/period can be 
assigned to shapes and then retrieved using the Identify tool.

12 Optional – Adding Attribute (Column) data
We may wish to attach other data to the archaeological features, such as what period they date 
from. Undertake this if there is time!

1. Toggle editing on and then open the attribute table for Archaeological Feature (right click > 
Open attribute table).

2. Click on the New Column button at the top right 

3. Fill in the details for a new column (attribute) called Period, of type
Text with width 20.

4. Press OK.

5. Suppose in post-excavation we assign the following periods to the
features, fill in each cell in the table by double clicking the cell,
typing in the period and pressing enter. Leave NULL as it is (for undated)

NOTE: There are more efficient way of doing this with larger data sets automatically – but 
that's a more advanced course!

6. Save the layer. 

With this data now entered, you can colour code the features according to period automatically. 
Details of colour styling according to attribute are covered in the Level 1 course and also in the 
field walking exercise below.

1. Go into the Archaeological Feature layer's style tab (Right click>Layer Properties>Style) 
and choose 'Categorised' styles from the top right and Column: 'Period'.

2. Press Classify and a set of
categories will be generated:
Roman, Late Iron Age and a
blank one (for shapes with no
Period assigned).

3. You can edit each symbol by double clicking on it (there is a range of options), or leave 
them as they are.
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Demonstration – Tracing from Aerial Photographs
Due to time restrictions, there will be only a demonstration of this process. It is essentially the 
same process as digitising from site plans only working at a broader scale. If you are following this 
guide outside of the class, the points below summarise the process but you may need to refer 
back to earlier stages or the Level 1 guide. There are also many resources online if you search for 
specific QGIS features or troubleshooting.

• First georeference the aerial photograph using base mapping (e.g. download free basic 
mapping available from OS Open Data – an example was covered in the Level 1 guide). 
The image used here is:
https://commons.wikimedia.org/wiki/Category:RAF_Fowlmere#/media/File:Fowlmere-
13April1947.png

• Create a layer for features you want to trace (Layer>Create Layer>New Shapefile Layer...) 
– perhaps lines representing crop mark ditches (or in the example, airfield features)

• Digitise by tracing lines on the photographs

• Remove the photograph layer

• Work with traced data as required (styling, add attributes, print over base maps)

An alternative method is to use Google Earth. Within this you can trace lines (and check against 
historical imagery). If you organise a set of lines into a folder in 'My Places', you can export that 
folder as a KML file. Although this will be in a lat/long (not an easting/northing) co-ordinate system, 
QGIS will automatically display these lines in the correct locations for you to work with.

N.B. You can not trace entire maps from Google Earth:
https://www.google.co.uk/permissions/geoguidelines.html
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Exercise 2 – Field Walking Design

Introduction
This exercise shows you one way to set up a field walking project using only QGIS. Without using
other software it  is somewhat limited at this stage, producing only North-South/East-West grids
where you might have preferred to follow a major field boundary, for example.

Different projects may call  for different methodologies but this method provides a starting point
from creating a grid to displaying data collected in the field.

We will:

• Create a regular grid of points, fitting inside a defined walking area.

• Create a table of co-ordinates for those points (to use in the field or upload to GPS).

• Add our results to the table.

• Display our results in QGIS.

1 One-time Setup
We use the fTools plugin to create our grid.  Make sure you have the fTools plugin installed. This
may be installed  by default with QGIS 2.6 and later.

1. Plugins > Manage and Install  Plugins,  click  'Installed',  check  fTools is  installed  and  
ticked.

2. If it is not, click 'All', find it in there and install it.

2 Open the project
1. Find  and  open  the  project  file  in  Exercises/Exercise  2  -  Fieldwalking/Ex  2  –  Field

Walking.qgs (Project > Open)

1. This  project  file  contains  a  raster background map  (of  the  Clay  Farm  area,  now
redeveloped) and a  vector polygon shapefile layer with a single area digitised. This has
been created so that you all have the same file to work with, but you should know by now
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how to create a shapefile layer for your own projects.

2. Find the regular points tool (Vector>Research Tools>Regular Points...) NOTE: This 
requires the fTools plugin be installed.

3. Fill in these fields:

• Input Boundary Layer: 'Walking Boundary'. This
means our grid will be constrained to the polygon
around that field.
NOTE: If you choose 'Clay Farm Area' instead it will
grid the entire map! Slowly!

• Grid spacing: Use this point spacing: 20 (this is in
map units for a 20m grid).

• Output  shapefile: Click  Browse,  navigate  to
Exercises/Exercise  2  – Field walking/Shapefiles  and
call it something like 'Grid points'.

• Tick 'Add result to canvas'.

• Press OK. Wait. Press Close.

4. You should now have a grid of points over the whole area.
Look at the attribute table (right click > Open Attribute Table) for 'Grid Points' and you will 
see each point has an ID number – we will use this to tie our finds back to the point later.

5. Tell QGIS to display the ID number next to each
point (we covered this in the Level 1 exercises:
right click on the layer or click 
Layer>Properties...>Labels and then next to
'Label with', select 'ID').

6. You will probably also want to print this at various
scales (Project>Composer Manager.../Print
composers...) for reference when undertaking
the field work.
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3 Advanced – Clean up the grid
Please skip this step during the course as it may be time consuming. The following is provided for 
reference only.

The grid plugin is limited and still creates points outside of our walking boundary, within a square
area surrounding it. There are two options to get rid of unwanted points. One is to manually edit the
layer (right click or Layer>Toggle editing), select the unwanted points and delete them.

• Toggle editing for the layer

• Select: 

• Click and drag a rectangle around points you do not want

• Click Delete feature:   

• If you accidentally select the wrong points, use the Deselect Features from all Layers 
button:

• Finally save changes to the layer and turn editing off (Layer>Toggle editing)

4 Exporting points
Somehow we need to map these points onto the ground for field
walking.  Some  GPS  devices  may  just  accept  shapefiles
(remember  to  transfer  all  the  different  helper  files  too:  .shp,
.shx, .dbf, ...). KML or GML are also export formats that may work
with a hand-held GPS.

If  not,  the  most  useful  intermediate  format  is  CSV  (comma
separated variables). This is a text-based file which describes a
table and can be viewed in Excel or Calc. The other advantage is
these are human-readable, so if desperate, you can map out your
points by following printed co-ordinates.

We will also need this CSV file for our next step so we will export it
here.

1. Right click on the Grid Points layer. Choose Save As...

2. Choose the following options:

1. Format: Comma Separated Value [CSV].

2. Save as: Browse to Exercises/Exercise 2 – Field
walking/CSV and call the file 'Grid points export'.

3. Untick 'Add saved file to map' – we don't want another copy on the grid displayed at 
this point.

4. Leave most other options as they are, but check under Layer Options that:
GEOMETRY is set to AS_XY 
and SEPARATOR is set to COMMA.

5. Press OK and the window will disappear. This should now have now created a .csv file 
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containing x and y (easting and northing) coordinates for our field walking points. It 
should be possible to load this file into a handheld GPS. We will use this at the next 
stage.

5 Preparing for fieldwork
This step requires Excel or OpenOffice/Libre Office Calc. If you
do  not  have  either  of  those,  skip  this  step  as  a  finished,
populated field walking table has been prepared for you.

We are going to add columns matching each point ID with the
finds allocated to that point. The fieldwork methodology will vary
here but assume if we are walking from point A north to point B
then  all  finds  along  that  line  are  allocated  to  point  A.  This
methodology  will  depend  on  the  project  but  ultimately,  finds
have to be allocated to a point in a consistent manner.

1. Using windows explorer, browse to Exercises/Exercise 2
– Field walking/CSV folder and open the 'Grid points
export.csv' file. It should open with Excel/Calc, it may
prompt you with some options on how the file is read. If
the file won't open, try opening Libre/OpenOffice Calc or
Excel directly then open the file using File>Open...

2. You should see a table of X, Y (for the National Grid eastings and northings) and ID.  

The following steps will depend on your own project, a finished file has been provided for 
the next stages.

3. In practice, you would need to add additional columns for finds. Put the column title in the 
first row and numerical values only in the rows below.

4. You could always delete unwanted points at this stage (a job we skipped earlier) if they fall 
outside the area – just delete their rows from the table.

5. On saving, Excel/Calc will suggest you use their own formats. This is fine, but you will 
eventually need to convert back to CSV at the end of the work. This is done by clicking File 
> Save As... and choosing CSV as the format. NOTE that this format will eliminate any font 
styling, comments etc. that you have applied to the spreadsheet (so it is best to keep the 
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spreadsheet simple: columns, headings and numbers only). NEVER merge cells as this 
won't fit into the CSV format and QGIS won't understand it.

6 Data Entry
Your table then has to be updated with all relevant field walking data depending on your project 
methodology. An example has been prepared based on the grid we have used so far.

7 Re-importing Data
A mock-up table has been prepared with some fictional data filled in for each grid point. You can 
find it in the CSV folder: Exercises/Exercise 2 – Field walking/CSV called 'Grid points with data.csv'

You can open this to view in Excel/Calc, it will look like this:

1. Import this into QGIS: in the main window click
on Layer > Add Layer > Add Delimited Text
Layer… (as in the Level 1 course) and browsing
to the CSV folder, select 'Grid points with
data.csv'. Remember to map the X and Y fields
to X and Y (this should happen automatically). 

2. Ensure the preview looks sensible, like this (i.e.
column headings and data in the right places).

3. Press OK.

4. At this point, you can switch off the old 'Grid
points' layer in QGIS, it is no longer needed (and
may be confused with the results layer).

You will now have the 'Grid points with data' layer visible, but with a flat style and no labels.

What remains now is to style the layer, as was covered at the end of the Level 1 course (not 
everyone will have had time to do the last stage).
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8 Styling by Finds Type
1. Open layer styling (right click on the 'Grid points with data' layer,

click 'Layer properties...'; click on the style tab on the left hand
side).

2. Switch the drop down menu at the top left from 'Single Symbol' to
'Graduated'

3. In the 'Column' drop down, select 'Worked flint (g)'

4. Choose a 'Colour ramp' and press 'Classify'. This automatically generates coloured 
symbols according to the range of data values.

5. Optional: vary the size of the dots automatically according to mass:

• Click Advanced (lower left) > Size scale field > Worked flint (g)

6. Press Apply

This will now display only the points with worked flint data, hiding all the others.
They are also colour coded (and, optionally, sized) according to the value in the
'Worked flint (g)' field.

Within this Style window, using graduated styling you can assign different value ranges (instead of 
0-8, 8-16...) as customised symbols. You can also edit each legend item by double clicking on it. 
This will change the details displayed in the Layers pane. NOTE: Clicking 'Classify' again at any 
point will remove your styles and regenerate them based on the colour ramp and automatic 
ranges.

So far this only shows data for one column of our survey, Worked flint (g).

9 One Data Source, Multiple Layers
From here, you could, repeatedly switch the styling around to apply to different columns (Medieval 
sherds (count), Roman sherds (g)...) but you could still only display one at a time. In Level 1 it was 
covered that each layer on the left hand pane in QGIS represents a link to underlying data 
(shapefiles, raster, CSV...). This means that you can load a single data file as a layer more than 
once in the same project.

In this case we want to view a layer for each type of find, i.e. for each column in our field walking 
data. So we will load the same data file repeatedly as different layers, and style each layer to show 
what we want.

To keep track of this, we need to rename the layer in the Layers pane. NOTE: This does NOT 
change the name of the underlying CSV file.
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1. Rename 'Grid points with data' to 'Worked flint (g)'. Right click on the layer
and click rename, enter the new name.

2. Add the CSV layer again (Layer > Add Layer > Add Delimited Layer...) as
before. It will be added as 'Grid points with data' again.

3. Rename this layer as 'Roman sherds (g)' and then change its style as
before to Graduated, choosing a different colour ramp, and/or different symbol before 
pressing 'Classify'.

4. Optional: Set the size multiplier field to Roman sherds (g) (Advanced>Size scale 
field>Roman sherds (g))

5. Press ' OK'

We now have two layers in QGIS, both driven from one data source, our CSV file. If you update the

CSV file in Excel/Calc, the numbers will be reflected immediately in QGIS too.

You can repeat the process for the other data columns as layers. You are then free to turn each on 
and off as desired.
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Once all the data you wish to display is loaded into QGIS, you can add background mapping and 
other decorations for production of figures, using the print composer. (A brief introduction to the 
print composer is included with the Level 1 guide).
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